Tóm tắt nhanh
- CVE-2025-23207 là lỗ hổng mức CAO (CVSS 7.2) ảnh hưởng katex (katex), katex.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.41%, cao hơn 35.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.16.21 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| katex | ≥ 0.12.0, < 0.16.21
| 0.16.21
|
| katex npm | ≥ 0.12.0, < 0.16.21
| 0.16.21
|
Mô tả
Impact
KaTeX users who render untrusted mathematical expressions with renderToString could encounter malicious input using \htmlData that runs arbitrary JavaScript, or generate invalid HTML.
Patches
Upgrade to KaTeX v0.16.21 to remove this vulnerability.
Workarounds
- Avoid use of or turn off the
trust option, or set it to forbid \htmlData commands.
- Forbid inputs containing the substring
"\\htmlData".
- Sanitize HTML output from KaTeX.
Details
\htmlData did not validate its attribute name argument, allowing it to generate invalid or malicious HTML that runs scripts.
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions with `renderToString` could encounter malicious input using `\htmlData` that runs arbitrary JavaScript, or generate invalid HTML. Users are advised to upgrade to KaTeX v0.16.21 to remove this vulnerability. Users unable to upgrade should avoid use of or turn off the `trust` option, or set it to forbid `\htmlData` commands, forbid inputs containing the substring `"\\htmlData"` and sanitize HTML output from KaTeX.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí