Tóm tắt nhanh
- CVE-2025-24013 là lỗ hổng mức TRUNG BÌNH (CVSS 5.3) ảnh hưởng codeigniter4/framework, codeigniter (codeigniter).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.51%, cao hơn 43.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.5.8 hoặc mới hơn.
Mô tả
Impact
Lack of proper header validation for its name and value. The potential attacker can construct deliberately malformed headers with Header class. This could disrupt application functionality, potentially causing errors or generating invalid HTTP requests. In some cases, these malformed requests might lead to a DoS scenario if a remote service’s web application firewall interprets them as malicious and blocks further communication with the application.
Patches
Upgrade to v4.5.8 or later.
Workarounds
Validate HTTP header keys and/or values if using user-supplied values before passing them to Header class.
Differences from CVE-2023-29197
-
Affected Software:
- CVE-2023-29197 specifically addresses a vulnerability in the
guzzlehttp/psr7 library.
- The reported issue in this Security Advisory is within the CodeIgniter4 framework and does not depend on or use the
guzzlehttp/psr7 library.
-
Root Cause and Implementation:
- The vulnerability reported arises from an issue in the Header class of CodeIgniter4, which is unrelated to the functionality or implementation of
guzzlehttp/psr7.
-
Scope of Impact:
- The vulnerability described in this Security Advisory affects applications built with the CodeIgniter4 framework, which does not use or rely on the
guzzlehttp/psr7 library.
References
Mô tả của NVD
CodeIgniter is a PHP full-stack web framework. Prior to 4.5.8, CodeIgniter lacked proper header validation for its name and value. The potential attacker can construct deliberately malformed headers with Header class. This could disrupt application functionality, potentially causing errors or generating invalid HTTP requests. In some cases, these malformed requests might lead to a DoS scenario if a remote service’s web application firewall interprets them as malicious and blocks further communication with the application. This vulnerability is fixed in 4.5.8.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí