Tóm tắt nhanh
- CVE-2025-46344 là lỗ hổng mức TRUNG BÌNH (CVSS 4.9) ảnh hưởng @auth0/nextjs-auth0.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.44%, cao hơn 38.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.5.1 hoặc mới hơn.
Mô tả
Overview
Auth0 NextJS v4.0.1 to v4.5.0 does not invoke .setExpirationTime when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid.
Am I Affected?
You are affected if you are using Auth0 NextJS SDK v4.
Fix
Upgrade to v4.5.1.
Mô tả của NVD
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions starting from 4.0.1 and prior to 4.5.1, do not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. This issue has been patched in version 4.5.1.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí