Tóm tắt nhanh
- CVE-2025-46812 là lỗ hổng mức THẤP (CVSS 2.0) ảnh hưởng trix.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.72%, cao hơn 53.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.1.15 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| trix npm | < 2.1.15
| 2.1.15
|
Mô tả
Impact
The Trix editor, in versions prior to 2.1.15, is vulnerable to XSS attacks when pasting malicious code.
An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed.
Patches
Update Recommendation: Users should upgrade to Trix editor version 2.1.15 or later.
References
The XSS vulnerability was reported by HackerOne researcher hiumee.
Mô tả của NVD
Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.15 are vulnerable to XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. This issue has been patched in version 2.1.15.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí