Tóm tắt nhanh
- CVE-2025-47279 là lỗ hổng mức THẤP (CVSS 3.1) ảnh hưởng undici.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.34%, cao hơn 27.3% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.21.2, 7.5.0, 5.29.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| undici npm | ≥ 6.0.0, < 6.21.2≥ 7.0.0, < 7.5.0< 5.29.0
| 6.21.27.5.05.29.0
|
Mô tả
Impact
Applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak.
Patches
This has been patched in https://github.com/nodejs/undici/pull/4088.
Workarounds
If a webhook fails, avoid keep calling it repeatedly.
References
Reported as: https://github.com/nodejs/undici/issues/3895
Mô tả của NVD
Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí