Tóm tắt nhanh
- CVE-2025-5302 là lỗ hổng mức CAO (CVSS 8.6) ảnh hưởng llama-index-core.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.29%, cao hơn 21.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.12.38 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| llama-index-core PyPI | < 0.12.38
| 0.12.38
|
Mô tả
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.
Mô tả của NVD
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí