| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.apache.jackrabbit:jackrabbit-core | ≥ 2.20.0, < 2.20.17≥ 2.22.0, < 2.22.1≥ 2.23.0-beta, < 2.23.2-beta | 2.20.172.22.12.23.2-beta |
| org.apache.jackrabbit:jackrabbit-spi-commons | ≥ 2.20.0, < 2.20.17≥ 2.22.0, < 2.22.1≥ 2.23.0-beta, < 2.23.2-beta | 2.20.172.22.12.23.2-beta |
| jackrabbit | = 2.22.0= 2.23.0= 2.23.1≥ 2.20.0, < 2.20.17 | 2.20.17 |
Blind XXE vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges.
Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí