Tóm tắt nhanh
- CVE-2025-57809 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng xgrammar, xgrammar (mlc-ai).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.48%, cao hơn 41.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.1.21 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| xgrammar PyPI | < 0.1.21
| 0.1.21
|
| xgrammar | < 0.1.21
| 0.1.21
|
Mô tả
Summary
This issue: http://github.com/mlc-ai/xgrammar/issues/250 should have it's own security advisory. Since several tools accept and pass user supplied grammars to xgrammar, and it is so easy to trigger it seems like a High.
Mô tả của NVD
XGrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to version 0.1.21, XGrammar has an infinite recursion issue in the grammar. This issue has been resolved in version 0.1.21.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí