Tóm tắt nhanh
- CVE-2025-61594 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng uri, uri (ruby-lang).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.56%, cao hơn 46.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.13.3, 1.0.4, 0.12.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| uri RubyGems | ≥ 0.13.0, < 0.13.3≥ 1.0.0, < 1.0.4< 0.12.5
| 0.13.31.0.40.12.5
|
| uri | ≥ 0.13.0, < 0.13.3≥ 1.0.0, < 1.0.4< 0.12.5
| 0.13.31.0.40.12.5
|
Mô tả
Impact
In affected URI version, a bypass exists for the fix to CVE-2025-27221 that can expose user credentials.
When using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure.
The vulnerability affects the uri gem bundled with the following Ruby series:
- 0.12.4 and earlier (bundled in Ruby 3.2 series)
- 0.13.2 and earlier (bundled in Ruby 3.3 series)
- 1.0.3 and earlier (bundled in Ruby 3.4 series)
Patches
Upgrade to 0.12.5, 0.13.3 or 1.0.4
References
Mô tả của NVD
URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí