Tóm tắt nhanh
- CVE-2025-67746 là lỗ hổng mức TRUNG BÌNH (CVSS 4.3) ảnh hưởng composer/composer, composer (getcomposer).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.45%, cao hơn 39.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.2.26, 2.9.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| composer/composer Packagist | ≥ 2.0.0, < 2.2.26≥ 2.3.0, < 2.9.3
| 2.2.262.9.3
|
| composer | ≥ 2.0.0, < 2.2.26≥ 2.3.0, < 2.9.3
| 2.2.262.9.3
|
Mô tả
Impact
Attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application.
There is no proven exploit and this has thus a low severity but Composer still published a CVE as it has potential for abuse, and Composer wants to be on the safe side informing users that they should upgrade.
Patches
2.2.26 for 2.2 LTS or 2.9.3 for mainline.
Mô tả của NVD
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí