Tóm tắt nhanh
- CVE-2025-68438 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng apache-airflow, airflow (apache).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.62%, cao hơn 49.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.1.6 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| apache-airflow PyPI | ≥ 3.1.0, < 3.1.6
| 3.1.6
|
| airflow | ≥ 3.1.0, < 3.1.6
| 3.1.6
|
Mô tả
In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display.
Users are recommended to upgrade to 3.1.6 or later, which fixes this issue
Mô tả của NVD
In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display.
Users are recommended to upgrade to 3.1.6 or later, which fixes this issue
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí