Tóm tắt nhanh
- CVE-2026-105867 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng payload (payloadcms), @payloadcms/storage-s3.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.22%, cao hơn 12.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.90.0, 4.0.0-canary.34 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| payload | = 4.0.0< 3.90.0
| 3.90.0
|
| @payloadcms/storage-s3 npm | ≥ 4.0.0-canary.0, < 4.0.0-canary.34< 3.90.0
| 4.0.0-canary.343.90.0
|
Mô tả
Impact
An authenticated user could overwrite an existing S3 object belonging to another upload collection, bypassing that collection’s access controls and prior file validation.
You are affected if ALL of these are true:
- Client uploads are enabled for multiple collections that share an S3 bucket.
- useCompositePrefixes is not configured or is set to
false.
Patches
Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Workarounds
Disable client uploads until you can upgrade.
Mô tả của NVD
Payload is a free and open source headless content management system. In @payloadcms/storage-s3 versions before 3.90.0 and canary versions before 4.0.0-canary.34, an authenticated user can overwrite an existing S3 object belonging to another upload collection when client uploads are enabled for multiple collections sharing a bucket and useCompositePrefixes is false or unset. This bypasses the target collection's access controls and prior file validation. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí