Tóm tắt nhanh
- CVE-2026-115580 là lỗ hổng mức CAO (CVSS 7.1) ảnh hưởng pypdf.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.41%, cao hơn 35.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.21.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| pypdf PyPI | < 6.21.2
| 6.21.2
|
Mô tả
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires opening a file with large/wrong upper limits in the xref table.
Patches
This has been fixed in pypdf==6.21.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #4239.
Mô tả của NVD
pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF with a standard cross-reference table whose declared entry count exceeds what the file can contain, causing excessive processing and long runtimes when the file is opened. This issue is fixed in version 6.21.2.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí