| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| @ckeditor/ckeditor5-engine | ≥ 45.0.0, < 47.7.4≥ 48.0.0, < 48.5.1 | 47.7.448.5.1 |
| ckeditor5 | ≥ 45.0.0, < 47.7.4≥ 48.0.0, < 48.5.1 | 47.7.448.5.1 |
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values.
The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.
The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).
Email us at [email protected] if you have any questions or comments about this advisory.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí