Tóm tắt nhanh
- CVE-2026-26974 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng slyde (slyde.js), @tygo-van-den-hurk/slyde.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.61%, cao hơn 49.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.0.5 hoặc mới hơn.
Mô tả
Impact
This is a remote code execution (RCE) vulnerability. Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file could execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages.
Patches
The issue has been patched in v0.0.5. Users should upgrade to v0.0.5 or later to mitigate the vulnerability.
Workarounds
- Audit and restrict which packages are installed in
node_modules.
References
Mô tả của NVD
Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí