Tóm tắt nhanh
- CVE-2026-27578 là lỗ hổng mức TRUNG BÌNH (CVSS 5.4) ảnh hưởng n8n (n8n), n8n.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.22%, cao hơn 12.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.9.3, 2.10.1, 1.123.22 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| n8n | ≥ 2.0.0, < 2.9.3≥ 2.10.0, < 2.10.1< 1.123.22
| 2.9.32.10.11.123.22
|
| n8n npm | ≥ 2.0.0, < 2.9.3≥ 2.10.0, < 2.10.1< 1.123.22
| 2.9.32.10.11.123.22
|
Mô tả
Impact
An authenticated user with permission to create or modify workflows could inject arbitrary scripts into pages rendered by the n8n application using different techniques on various nodes (Form Trigger node, Chat Trigger node, Send & Wait node, Webhook Node, and Chat Node). Scripts injected by a malicious workflow execute in the browser of any user who visits the affected page, enabling session hijacking and account takeover.
Patches
The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Limit workflow creation and editing permissions to fully trusted users only.
- Disable the Webhook node by adding
n8n-nodes-base.webhook to the NODES_EXCLUDE environment variable.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Credit
Reporters:
- @ori-ron
- @Aikido-Security
- @nil340
- Pawel Bednarz from the NATO Cyber Security Centre (NCSC)
Mô tả của NVD
n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, an authenticated user with permission to create or modify workflows could inject arbitrary scripts into pages rendered by the n8n application using different techniques on various nodes (Form Trigger node, Chat Trigger node, Send & Wait node, Webhook Node, and Chat Node). Scripts injected by a malicious workflow execute in the browser of any user who visits the affected page, enabling session hijacking and account takeover. The issues have been fixed in n8n versions 2.10.1 and 1.123.21. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Webhook node by adding `n8n-nodes-base.webhook` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí