Tóm tắt nhanh
- CVE-2026-27971 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng qwik (qwik), @builder.io/qwik.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 5.5%, cao hơn 92.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.19.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| qwik | < 1.19.1
| 1.19.1
|
| @builder.io/qwik npm | < 1.19.1
| 1.19.1
|
Mô tả
Summary
qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime.
Impact
Mô tả của NVD
Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí