Tóm tắt nhanh
- CVE-2026-31828 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng parse-server (parseplatform), parse-server.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.45%, cao hơn 39.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 9.5.2, 8.6.26, 9.5.2-alpha.13 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| parse-server | = 9.5.2≥ 9.0.0, < 9.5.2< 8.6.26
| 9.5.28.6.26
|
| parse-server npm | ≥ 9.0.0-alpha.1, < 9.5.2-alpha.13< 8.6.26
| 9.5.2-alpha.138.6.26
|
Mô tả
Impact
The LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group.
The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control.
Patches
The vulnerability is fixed by escaping user input before interpolation into DN strings (per RFC 4514) and LDAP filter strings (per RFC 4515).
Workarounds
There is no known workaround.
References
Mô tả của NVD
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí