Tóm tắt nhanh
- CVE-2026-32248 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng parse-server (parseplatform), parse-server.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.64%, cao hơn 50.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 9.6.0, 8.6.38, 9.6.0-alpha.12 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| parse-server | = 9.6.0≥ 9.0.0, < 9.6.0< 8.6.38
| 9.6.08.6.38
|
| parse-server npm | ≥ 9.0.0, < 9.6.0-alpha.12< 8.6.38
| 9.6.0-alpha.128.6.38
|
Mô tả
Impact
An unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable.
Patches
The fix enforces that the user identifier in authentication data is a string before using it in a database query. Non-string values are rejected with a validation error.
Workarounds
There is no known workaround.
References
Mô tả của NVD
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí