| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.xwiki.platform:xwiki-platform-legacy-oldcore | ≥ 17.0.0-rc-1, < 17.4.8≥ 17.5.0-rc-1, < 17.10.1 | 17.4.817.10.1 |
| org.xwiki.platform:xwiki-platform-oldcore | ≥ 17.0.0-rc-1, < 17.4.8≥ 17.5.0-rc-1, < 17.10.1 | 17.4.817.10.1 |
| xwiki | ≥ 17.0.0, < 17.4.8≥ 17.5.0, < 17.10.1 | 17.4.817.10.1 |
An improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users.
The vulnerability has been patched in XWiki 17.4.8 and 17.10.1 by requiring programming right to access the affected scripting API.
We're not aware of any workarounds except for being careful whom you grant script right.
We thank Youssef Azefzaf for discovering and reporting this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí