Tóm tắt nhanh
- CVE-2026-34052 là lỗ hổng mức TRUNG BÌNH (CVSS 5.9) ảnh hưởng jupyterhub-ltiauthenticator, lti jupyterhub authenticator (jupyter).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.34%, cao hơn 27.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.6.3 hoặc mới hơn.
Mô tả
Summary
The LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service.
Patches
- upgrade jupyterhub-litauthenticator to 1.6.3
Mô tả của NVD
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí