| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.apache.atlas:apache-atlas | ≥ 0.8, < 2.5.0 | 2.5.0 |
| atlas | ≥ 0.8, < 2.5.0 | 2.5.0 |
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Atlas.
Apache Atlas exposes a DSL search endpoint that accepts user-supplied query strings. Attacker can alter Gremlin traversal logic within grammar-allowed characters to access unintended data.
This issue affects Apache Atlas: from 0.8-incubating through 2.4.0.
For affected versions >= 2.0.0, the vulnerability is only exploitable when Atlas is deployed with below non-default configuration.
atlas.dsl.executor.traversal=false
Users are recommended to upgrade to version 2.5.0, which fixes the issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí