| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| dos | = 4.9.0≥ 4.3.0, ≤ 4.7.0 | |
| nginx gateway fabric | ≥ 1.3.0, ≤ 1.6.2≥ 2.0.0, ≤ 2.6.3 | |
| nginx ingress controller | ≥ 3.5.0, ≤ 3.7.2≥ 4.0.0, ≤ 4.0.1≥ 5.0.0, ≤ 5.5.0 | |
| nginx instance manager | ≥ 2.17.0, ≤ 2.22.0 | |
| nginx open source | ≥ 1.0.0, ≤ 1.30.2≥ 1.31.0, ≤ 1.31.1 | |
| nginx plus | = r36≥ 37.0.0.1, < 37.0.2.1≥ r33, < r36 | 37.0.2.1r36 |
| waf | ≥ 4.10.0, ≤ 4.16.0≥ 5.2.0, ≤ 5.8.0≥ 5.9.0, ≤ 5.13.1 | |
| update infrastructure | ≥ 5.0, < 5.2 | 5.2 |
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_proxy_v2_module and ngx_http_grpc_module modules. This vulnerability exists when the proxy_http_version to 2 or grpc_pass directives are used to proxy HTTP/2 traffic, the ignore_invalid_headers directive is set to off, and the large_client_header_buffers directive size is larger than 2 megabytes. A remote, unauthenticated attacker, along with conditions beyond their control, could send large headers while creating an upstream request. This may cause a heap-based buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí