| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.apache.syncope.core:syncope-core-provisioning-api | ≥ 3.0.0-M0, ≤ 3.0.16≥ 4.0.0-M0, < 4.0.6≥ 4.1.0-M0, < 4.1.1 | 4.0.64.1.1 |
| syncope | = 4.1.0≥ 3.0.0, ≤ 3.0.16≥ 4.0.0, < 4.0.6 | 4.0.6 |
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.
An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information.
This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.
Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí