Tóm tắt nhanh
- CVE-2026-48069 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng @grpc/grpc-js.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.88%, cao hơn 59.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.10.12, 1.11.4, 1.12.7, 1.13.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| @grpc/grpc-js npm | ≥ 1.10.0, < 1.10.12≥ 1.11.0, < 1.11.4≥ 1.12.0, < 1.12.7≥ 1.13.0, < 1.13.5≥ 1.14.0, < 1.14.4< 1.9.16
| 1.10.121.11.41.12.71.13.51.14.41.9.16
|
Mô tả
Impact
An invalid incoming compressed message can cause a client or server process to crash. This affects all clients and servers that use @grpc/grpc-js
Patches
The following version have fixes for this vulnerability:
- 1.9.16
- 1.10.12
- 1.11.4
- 1.12.7
- 1.13.5
- 1.14.4
Workarounds
There is no workaround.
Mô tả của NVD
@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming compressed message can cause a client or server process that uses @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí