Tóm tắt nhanh
- CVE-2026-59898 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng io.netty:netty-codec-http, netty (netty).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.44%, cao hơn 38.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.2.16.Final, 4.1.136.Final, 4.2.16, 4.1.136 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| io.netty:netty-codec-http Maven | ≥ 4.2.0.Final, < 4.2.16.Final< 4.1.136.Final
| 4.2.16.Final4.1.136.Final
|
| netty | ≥ 4.2.0, < 4.2.16< 4.1.136
| 4.2.164.1.136
|
Mô tả
Summary
An attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending Sec-WebSocket-Version: 7 and omitting Connection: Upgrade / Upgrade: websocket headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks.
Mô tả của NVD
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí