| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| n8n | = 2.32.0≥ 2.31.0, < 2.31.5< 1.123.67 | 2.31.51.123.67 |
| n8n | ≥ 2.0.0-rc.0, < 2.31.5≥ 2.32.0, < 2.32.1< 1.123.67 | 2.31.52.32.11.123.67 |
The Postgres Trigger node interpolated user-supplied identifier parameters (channel, function, and trigger names) into SQL statements without proper escaping, so an authenticated user could inject arbitrary SQL executed against the connected PostgreSQL database with the configured credential's privileges.
Successful exploitation allows full read and write access to the connected PostgreSQL database.
The issue has been fixed in n8n versions 1.123.67, 2.31.5 and 2.32.1. Users should upgrade to these versions or later to remediate the vulnerability.
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
n8n-nodes-base.postgresTrigger to the NODES_EXCLUDE environment variable.These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí