Tóm tắt nhanh
- CVE-2026-81176 là lỗ hổng mức TRUNG BÌNH (CVSS 5.3) ảnh hưởng devalue.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.51%, cao hơn 43.3% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 5.9.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| devalue npm | < 5.9.2
| 5.9.2
|
Mô tả
Impact
devalue.parse prior to version 5.9.2 fails to reject out-of-bounds indices. Specially-crafted payloads can exploit this to cause devalue to alternate between different array representations, resulting in work that is quadratic with payload size.
Applications are potentially affected if they call devalue.parse with untrusted data.
Patches
The bug is fixed in [email protected].
Mô tả của NVD
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. Prior to 5.9.2, devalue.parse does not reject out-of-bounds indices that are greater than or equal to values.length in src/parse.js. A specially crafted untrusted payload can make the parser alternate between array representations, producing quadratic work as the payload grows and causing denial of service in applications that parse untrusted devalue data. This issue is fixed in version 5.9.2.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí