要点
- CVE-2024-22207 是影响 swagger ui (smartbear), @fastify/swagger-ui 的中危 (CVSS 5.3)漏洞。
- 未来 30 天内被利用的概率(EPSS):2.3%,高于 83.2% 的漏洞。
- 修复:升级到 2.1.0 或更高版本。
Description
Impact
The default configuration of @fastify/swagger-ui without baseDir set will lead to all files in the module's directory being exposed via http routes served by the module.
Patches
Update to v2.1.0
Workarounds
Use the baseDir option
References
HackerOne report
.
NVD description
fastify-swagger-ui is a Fastify plugin for serving Swagger UI. Prior to 2.1.0, the default configuration of `@fastify/swagger-ui` without `baseDir` set will lead to all files in the module's directory being exposed via http routes served by the module. The vulnerability is fixed in v2.1.0. Setting the `baseDir` option can also work around this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free