| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.kylin:kylin | ≥ 4.0.0, < 5.0.2 | 5.0.2 |
| kylin | ≥ 4.0.0, < 5.0.2 | 5.0.2 |
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected.
This issue affects Apache Kylin: from 4.0.0 through 5.0.1.
Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free