要点
- CVE-2026-55228 是影响 weblate 的高危 (CVSS 8.1)漏洞。
- 未来 30 天内被利用的概率(EPSS):0.45%,高于 39.0% 的漏洞。
- 修复:升级到 2026.7 或更高版本。
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 2026.7
| 2026.7
|
Description
Impact
The API did not properly handle project- and workspace-scoped teams and allowed setting invalid configurations, including granting access to projects the user has no access to.
Patches
References
Parts of this issue were independently reported by four reporters:
NVD description
Weblate is a web-based continuous localization platform used to manage software translations. In versions prior to 2026.7, the REST API did not properly enforce the scope of project- and workspace-scoped teams, allowing a user to submit invalid team configurations through the API. By assigning projects to a team via these unvalidated requests, a user could grant access to projects they were not authorized to see or manage. This could expose private projects and permit translation, repository, and project-management operations outside the user's intended permission scope. This issue is fixed in version 2026.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free