In short
- CVE-2007-6737 is a HIGH (CVSS 7.5) vulnerability affecting pyftpdlib, pyftpdlib (g.rodola).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.8% of all vulnerabilities.
- Fix: update to 0.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pyftpdlib PyPI | < 0.2.0
| 0.2.0
|
| pyftpdlib | = 0.1≤ 0.1.1
| No fix yet |
Description
FTPServer.py in pyftpdlib before 0.2.0 does not increment the attempted_logins count for a USER command that specifies an invalid username, which makes it easier for remote attackers to obtain access via a brute-force attack.
NVD description
FTPServer.py in pyftpdlib before 0.2.0 does not increment the attempted_logins count for a USER command that specifies an invalid username, which makes it easier for remote attackers to obtain access via a brute-force attack.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free