In short
- CVE-2008-7262 is a MEDIUM (CVSS 6.5) vulnerability affecting pyftpdlib, pyftpdlib (g.rodola).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 81.2% of all vulnerabilities.
- Fix: update to 0.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pyftpdlib PyPI | < 0.3.0
| 0.3.0
|
| pyftpdlib | = 0.1= 0.1.1≤ 0.2.0
| No fix yet |
Description
Multiple directory traversal vulnerabilities in FTPServer.py in pyftpdlib before 0.3.0 allow remote authenticated users to access arbitrary files and directories via vectors involving a symlink in a pathname to a (1) CWD, (2) DELE, (3) STOR, or (4) RETR command.
NVD description
Multiple directory traversal vulnerabilities in FTPServer.py in pyftpdlib before 0.3.0 allow remote authenticated users to access arbitrary files and directories via vectors involving a symlink in a pathname to a (1) CWD, (2) DELE, (3) STOR, or (4) RETR command.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free