In short
- CVE-2011-4953 is a MEDIUM (CVSS 6.8) vulnerability affecting cobbler, cobbler (cobbler project).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.5% of all vulnerabilities.
- Fix: update to 2.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| cobbler PyPI | < 2.6.0
| 2.6.0
|
| cobbler | ≤ 2.2.1
| No fix yet |
Description
The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.
NVD description
The set_mgmt_parameters function in item.py in cobbler before 2.2.2 allows context-dependent attackers to execute arbitrary code via vectors related to the use of the yaml.load function instead of the yaml.safe_load function, as demonstrated using Puppet.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free