In short
- CVE-2012-2139 is a MEDIUM (CVSS 5.0) vulnerability affecting mail, mail gem (rubygems).
- Chance of exploitation in the next 30 days (EPSS): 4.9%, higher than 92.1% of all vulnerabilities.
- Fix: update to 2.4.4 or later.
| Package | Affected versions | Patched versions |
|---|
| mail RubyGems | < 2.4.4
| 2.4.4
|
| mail gem | = 2.3.2= 2.3.3= 2.4.1≤ 2.4.3
| No fix yet |
Description
Directory traversal vulnerability in lib/mail/network/delivery_methods/file_delivery.rb in the Mail gem before 2.4.4 for Ruby allows remote attackers to read arbitrary files via a .. (dot dot) in the to parameter.
NVD description
Directory traversal vulnerability in lib/mail/network/delivery_methods/file_delivery.rb in the Mail gem before 2.4.4 for Ruby allows remote attackers to read arbitrary files via a .. (dot dot) in the to parameter.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free