In short
- CVE-2012-2140 is a HIGH (CVSS 7.5) vulnerability affecting mail, mail gem (rubygems).
- Chance of exploitation in the next 30 days (EPSS): 4.5%, higher than 91.4% of all vulnerabilities.
- Fix: update to 2.4.3 or later.
| Package | Affected versions | Patched versions |
|---|
| mail RubyGems | < 2.4.3
| 2.4.3
|
| mail gem | = 2.3.2= 2.3.3≤ 2.4.1
| No fix yet |
Description
The Mail gem before 2.4.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a (1) sendmail or (2) exim delivery.
NVD description
The Mail gem before 2.4.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a (1) sendmail or (2) exim delivery.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free