In short
- CVE-2015-9097 is a MEDIUM (CVSS 6.1) vulnerability affecting mail, mail (mail project).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 88.8% of all vulnerabilities.
- Fix: update to 2.5.5 or later.
| Package | Affected versions | Patched versions |
|---|
| mail RubyGems | < 2.5.5
| 2.5.5
|
| mail | ≤ 2.5.4
| No fix yet |
Description
The mail gem before 2.5.5 for Ruby (aka A Really Ruby Mail Library) is vulnerable to SMTP command injection via CRLF sequences in a RCPT TO or MAIL FROM command, as demonstrated by CRLF sequences immediately before and after a DATA substring.
NVD description
The mail gem before 2.5.5 for Ruby (aka A Really Ruby Mail Library) is vulnerable to SMTP command injection via CRLF sequences in a RCPT TO or MAIL FROM command, as demonstrated by CRLF sequences immediately before and after a DATA substring.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free