In short
- CVE-2012-2395 is a HIGH (CVSS 7.5) vulnerability affecting cobbler, cobbler (michael dehaan).
- Chance of exploitation in the next 30 days (EPSS): 5.5%, higher than 92.8% of all vulnerabilities.
- Fix: update to 2.6.0 or later.
| Package | Affected versions | Patched versions |
|---|
| cobbler PyPI | < 2.6.0
| 2.6.0
|
| cobbler | = 2.2.0
| No fix yet |
Description
A Command Injection in action_power.py in Cobbler prior to v2.6.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) username or (2) password fields to the power_system method in the xmlrpc API.
NVD description
Incomplete blacklist vulnerability in action_power.py in Cobbler 2.2.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) username or (2) password fields to the power_system method in the xmlrpc API.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free