In short
- CVE-2012-4449 is a CRITICAL (CVSS 9.8) vulnerability affecting org.apache.hadoop:hadoop-client, hadoop (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.0% of all vulnerabilities.
- Fix: update to 1.0.4, 2.0.2, 0.23.4 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.hadoop:hadoop-client Maven | ≥ 1.0.0, < 1.0.4≥ 2.0.0, < 2.0.2< 0.23.4
| 1.0.42.0.20.23.4
|
| hadoop | = 1.0.0= 1.0.1= 1.0.2= 1.0.3= 2.0.0= 2.0.1= 2.0.2≤ 0.23.3
| No fix yet |
Description
Apache Hadoop before 0.23.4, 1.x before 1.0.4, and 2.x before 2.0.2 generate token passwords using a 20-bit secret when Kerberos security features are enabled, which makes it easier for context-dependent attackers to crack secret keys via a brute-force attack.
NVD description
Apache Hadoop before 0.23.4, 1.x before 1.0.4, and 2.x before 2.0.2 generate token passwords using a 20-bit secret when Kerberos security features are enabled, which makes it easier for context-dependent attackers to crack secret keys via a brute-force attack.
More vulnerabilities in org.apache.hadoop:hadoop-client
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free