In short
- CVE-2017-3161 is a MEDIUM (CVSS 6.1) vulnerability affecting org.apache.hadoop:hadoop-client, hadoop (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.9%, higher than 90.2% of all vulnerabilities.
- Fix: update to 2.7.0 or later.
Description
The HDFS web UI in Apache Hadoop before 2.7.0 is vulnerable to a cross-site scripting (XSS) attack through an unescaped query parameter.
NVD description
The HDFS web UI in Apache Hadoop before 2.7.0 is vulnerable to a cross-site scripting (XSS) attack through an unescaped query parameter.
More vulnerabilities in org.apache.hadoop:hadoop-client
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free