In short
- CVE-2017-3162 is a HIGH (CVSS 7.3) vulnerability affecting org.apache.hadoop:hadoop-client, hadoop (apache).
- Chance of exploitation in the next 30 days (EPSS): 6.4%, higher than 93.7% of all vulnerabilities.
- Fix: update to 2.7.0 or later.
Description
HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.
NVD description
HDFS clients interact with a servlet on the DataNode to browse the HDFS namespace. The NameNode is provided as a query parameter that is not validated in Apache Hadoop before 2.7.0.
More vulnerabilities in org.apache.hadoop:hadoop-client
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free