In short
- CVE-2015-4706 is a MEDIUM (CVSS 6.1) vulnerability affecting ipython, ipython (ipython).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.7% of all vulnerabilities.
- Fix: update to 3.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ipython PyPI | ≥ 3.0.0, < 3.2.0
| 3.2.0
|
| ipython | = 3.0.0= 3.1.0
| No fix yet |
Description
Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/contents path.
NVD description
Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/contents path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free