In short
- CVE-2015-4707 is a MEDIUM (CVSS 6.1) vulnerability affecting ipython, ipython (ipython).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.1% of all vulnerabilities.
- Fix: update to 3.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| ipython PyPI | < 3.2.0
| 3.2.0
|
| ipython | < 3.2.0
| 3.2.0
|
Description
Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path.
NVD description
Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free