In short
- CVE-2015-7337 is a MEDIUM (CVSS 6.8) vulnerability affecting ipython, notebook, notebook (ipython).
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.6% of all vulnerabilities.
- Fix: update to 3.2.2, 4.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ipython PyPI | < 3.2.2
| 3.2.2
|
| notebook PyPI | ≥ 4.0.0, < 4.0.5
| 4.0.5
|
| notebook | ≤ 3.2.1
| No fix yet |
| notebook | = 4.0.0= 4.0.1= 4.0.2= 4.0.3= 4.0.4
| No fix yet |
Description
The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.
NVD description
The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free