In short
- CVE-2015-6938 is a MEDIUM (CVSS 4.3) vulnerability affecting ipython, notebook, notebook (ipython).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.4% of all vulnerabilities.
- Fix: update to 3.2.2, 4.0.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ipython PyPI | < 3.2.2
| 3.2.2
|
| notebook PyPI | ≥ 4.0.0, < 4.0.5
| 4.0.5
|
| notebook | ≤ 3.2.1
| No fix yet |
| notebook | = 4.0.0= 4.0.1= 4.0.2= 4.0.3= 4.0.4
| No fix yet |
Description
Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbitrary web script or HTML via a folder name. NOTE: this was originally reported as a cross-site request forgery (CSRF) vulnerability, but this may be inaccurate.
NVD description
Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbitrary web script or HTML via a folder name. NOTE: this was originally reported as a cross-site request forgery (CSRF) vulnerability, but this may be inaccurate.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free