In short
- CVE-2016-0785 is a HIGH (CVSS 8.8) vulnerability affecting org.apache.struts:struts2-core, struts (apache).
- Chance of exploitation in the next 30 days (EPSS): 8.9%, higher than 95.2% of all vulnerabilities.
- Fix: update to 2.3.20.3, 2.3.24.3 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.struts:struts2-core Maven | ≥ 2.0.0, < 2.3.20.3≥ 2.3.24, < 2.3.24.3
| 2.3.20.32.3.24.3
|
| struts | ≥ 2.0.0, < 2.3.20.3≥ 2.3.21, ≤ 2.3.24.1
| 2.3.20.3
|
Description
Apache Struts 2.x before 2.3.20.3, 2.3.24.3, and 2.3.28 allows remote attackers to execute arbitrary code via a %{} sequence in a tag attribute, aka forced double OGNL evaluation.
NVD description
Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.
More vulnerabilities in org.apache.struts:struts2-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free