In short
- CVE-2017-1000056 is a CRITICAL (CVSS 9.8) vulnerability affecting k8s.io/kubernetes, kubernetes (kubernetes).
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.7% of all vulnerabilities.
- Fix: update to 1.5.5 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/kubernetes Go | ≥ 1.5.0, < 1.5.5
| 1.5.5
|
| kubernetes | = 1.5.0= 1.5.1= 1.5.2= 1.5.3= 1.5.4
| No fix yet |
Description
Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.
NVD description
Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.
More vulnerabilities in k8s.io/kubernetes
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free