In short
- CVE-2017-1000188 is a MEDIUM (CVSS 6.1) vulnerability affecting ejs (ejs), ejs.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 69.0% of all vulnerabilities.
- Fix: update to 2.5.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ejs | < 2.5.5
| 2.5.5
|
| ejs npm | < 2.5.5
| 2.5.5
|
Description
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
NVD description
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free