In short
- CVE-2017-1000228 is a CRITICAL (CVSS 9.8) vulnerability affecting ejs (ejs), ejs.
- Chance of exploitation in the next 30 days (EPSS): 6.3%, higher than 93.6% of all vulnerabilities.
- Fix: update to 2.5.3, 2.5.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ejs | < 2.5.3
| 2.5.3
|
| ejs npm | < 2.5.5
| 2.5.5
|
Description
nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function
NVD description
nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free