In short
- CVE-2017-1000189 is a HIGH (CVSS 7.5) vulnerability affecting ejs (ejs), ejs.
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.0% of all vulnerabilities.
- Fix: update to 2.5.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ejs | < 2.5.5
| 2.5.5
|
| ejs npm | < 2.5.5
| 2.5.5
|
Description
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in ejs.renderFile()
NVD description
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free